Apperçu

PUKABO

version 3.2.0.0
28 avril 2024

Henri Serindat

Un outil simple de sauvegarde pour Windows®.

Dans cet exemple, Z: est l'unité de sauvegarde avec environ 8 Go libres.

Le bouton de sauvegarde (en haut à droite) démarre la sauvegarde.

La table des dossier contient la liste des dossiers à sauvegarder. Seuls ceux qui sont cochés seront sauvegardés (1 dans cet exemple).

Dans la table du bas s'affichent les messages d'exécution.

  • La configuration de sauvegarde et l'historique sont enregistrés dans l'unité de sauvegarde.
  • Aucun logiciel spécifique n'est nécessaire pour récupérer des fichiers et des dossiers.
  • PUKABO offre une deuxième chance pour récupérer des fichiers perdus suite à une erreur humaine.

Windows® est une marque déposée de Microsoft Corp. aux États-Unis et dans les autres pays.


Démarrage immédiat

  1. Insérez une clé USB (mémoire flash ou disque dur).
  2. Démarrez le programme PUKABO.
  3. Ajoutez une unité de sauvegarde c-à-d un disque de destination pour les données à sauvegarder : menu Configuration ► Unité de sauvegarde ► Ajouter. La clé USB doit apparaître dans la liste proposée : sélectionnez-la.
  4. Ajoutez des dossiers à sauvegarder : faîtes glisser des dossiers de l'explorateur Windows vers la liste des dossiers. (Un explorateur de dossiers est inclus dans PUKABO)
  5. Cliquez sur le bouton Sauvegarder en haut à droite :
    Le programme analyse les dossiers à sauvegarder et affiche le nombre de fichiers dans chacun, le nombre de fichiers précédemment sauvegardés et le nombre fichiers à jour. Ceci peut prendre pluiseurs secondes pour les gros répertoires.
    Une boîte apparaît alors, indique le volume de données à sauvegarder. Cliquez sur Continuer.
  6. La sauvegarde s'effectue à environ 1 gigaoctet par minute.
    Des messages indiquent le nombre de fichiers à traiter dans chaque dossier.

Appuyez sur [F1] pour voir cette notice.

Comme vous pouvez voir, aucune configuration n'est nécessaire ; à partir de zéro, la première sauvegarde simple peut être réalisée en une minute.


Que s'est-il passé

Les dossiers définis à l'étape 4 ci-dessus sont insérés dans la configuration de sauvegarde et cochés par défaut. À l'étape 6, ils sont sauvegardés. On trouve alors dans l'unité de sauvegarde :

  • un dossier PUKABO qui contient l'arborescence de fichiers sauvegardés ;
  • un dossier PUKAB_ qui contient la version précédente des fichiers sauvegardés,
  • un fichier PUKABO.cfg qui contient la configuration de sauvegarde (liste des dossiers à sauvegarder et date de la dernière sauvegarde) ;
  • un fichier PUKABO.log avec le détail des opérations (peut être examiné avec tout éditeur de texte).

C'est la présence du fichier de configuration ( PUKABO.cfg ) qui différencie une unité de stockage ordinaire (disque) d'une unité de sauvegarde de PUKABO.

On recommence

Si l'on clique à nouveau sur le bouton Sauvegarder, le traitement se termine en quelques secondes avec le message A jour (pas de fichier à copier). En effet, PUBAKO ne copie pas les fichiers qui n'ont pas été modifiés.

PUKABO considère qu'un fichier n'a pas à être sauvegardé à nouveau si sa taille et sa date de modification correspondent à la sauvegarde précédente.


Liste des commandes

Opération sur les tables :

Clic gauche dans la colonne ◆ : sélectionne ou dé-sélectionne un élément (tous les éléments lorsque l'on clique dans l'en-tête).

Clic gauche sur • or • plie ou déplie le contenu d'un dossier (cf. Explorateur de dossiers ).

Clic droit dans la table des dossiers à sauvegarder : option pour ajouter ou retirer des dossiers.

Menu :

Programme

Sauvegarder

Quitter

Configuration

Unité de sauvegarde

Sélectionner

Ajouter

Retirer

Dossiers à sauvegarder

Ajouter

Retirer

Éléments sélectionnés

Éléments non sélectionnés

Aide

Voir l'aide : pour visualiser ce (la touche [F1] à le même effet)

Définir les couleurs

Configuration par défaut : couleurs par défaut

À propos...


Sécurité

La sécurité de vos données s'appuie sur un ensemble de précautions :

  • avoir deux système de sauvegarde complètement différents (PUKABO et un autre), ou à la rigueur un seul logiciel utilisé en alternance avec 2 unités de sauvegarde ;
  • prenez soin de vos unité de sauvegarde ; stockez-les dans des lieux différents.

Si des fichiers ont disparu de votre système, vous avez de bonnes chances de les retrouver dans le dossier PUKABO\ de l'unité de sauvegarde. Si vous avez effectué une sauvegarde après la perte des fichiers, ces fichiers auront été effacés de PUKABO\ ; vous les trouverez dans PUKABO_\ où ils resteront jusqu'à ce qu'une nouvelle version de ces fichiers soit créée et sauvegardée à nouveau.

En cas de sinistre sur votre système, ce qu'il ne faut surtout pas faire, c'est une sauvegarde sur l'unité habituelle, par exemple pour sauver éventuellement ce qui reste. Un système défaillant peut détruire le contenu de vos unités de sauvegarde ; vous risquez de tout perdre !

Dès qu'une anomalie est détectée, ne plus rien sauvegarder dans l'unité habituelle et repartir avec un nouveau support.

En cas de doute, examiner attentivement les rapports des dernières sauvegarde effectuées. Un utilitaire tel que kdiff3 ( http://kdiff3.sourceforge.net/ ) pourra également vous aider à comparer le contenu de votre système et celui de vos unités de sauvegarde.

"Ne pas prévoir, c'est déjà gémir." (Léonard de Vinci)


Explorateur de dossiers

Trois possibilités permettent d'ajouter des dossiers à sauvegarder :

  • En les faisant glisser à partir de l'explorateur ;
  • Au moyen d'un clic droit dans la table des dossier et en sélectionnant Ajouter ;
  • Menu Configuration ► Dossiers à sauvegarder ► Ajouter.

Les 2 dernières options utilisent l'explorateur de dossiers de PUKABO :

Cet explorateur propose :

  • Un bouton Rafraîchir.
  • Un bouton de sélection de l'unité à explorer (C: dans l'exemple ci-dessus).
  • Une colonne de gauche permettant de sélectionner ou dé-sélectionner des dossiers ;
  • Une colonne de dossiers :
    Un dossier contenant d'autres dossier apparaît avec une icône de dossier qui peut être plié ou déplié en cliquant dessus.
  • Un bouton Ajouter pour ajouter les dossiers sélectionnés, ou Fermer si aucun dossier n'est sélectionné.


Fichiers antidatés

Si un fichier a été modifié dans l'unité de sauvegarde et pas à son emplacement d'origine, PUKABO est à même de le détecter.

Ces fichiers apparaissent dans une table et l'utilisateur peut définir quoi faire :

  • Les fichiers cochés seront restaurés (copiés de l'unité de sauvegarde vers leur emplacement d'origine).
  • Les fichiers non cochés sont normalement sauvegardés (les modifications effectuées sur l'unité de sauvegarde seront perdues).


Questions fréquentes

Quels supports puis-je utiliser pour sauvegarder mes données ?

Tout support équivalent à un disque dur : interne ou externe, une mémoire flash USB, un disque dur USB ou un disque réseau, une carte mémoire...

Ces supports devraient utiliser le système de fichiers NTFS (ou exFAT). Le système FAT32 n'est recommandé car les changement d'heure (été/hiver) provoquent des incohérences.

On ne peut pas utiliser C:, un CD/DVD/BD ou une bande.

Puis-je utiliser PUKABO pour sauvegarder plusieurs ordinateurs sur la même unité de sauvegarde ?

Non. La version standard enregistre fichiers et répertoires avec un préfixe PUKABO (et PUKAB_) : la sauvegarde d'un ordinateur corromprait celle des autres.

Pour sauvegarder plusieurs ordinateurs, utilisez la version PRO comme indiqué dans la dernière réponse.

Puis-je sauvegarder n'importe quel disque ou n'importe quel répertoire ?

PUKABO peut sauvegarder un disque entier, mais les fichiers système et les dossiers cachés sont ignorés (RECYCLER, System Volume Information,...).

PUKABO supporte les disques réseau.

Qu'en est-il des « fichiers conservés » ?

Un fichier source et sa sauvegarde sont considérés comme identiques si leurs dates (à 2 s près) et leurs tailles sont identiques.

Seuls les nouveaux fichiers sont copiés sur l'unité de sauvegarde ; c'est pourquoi PUKABO est si rapide.

Lorsque PUKABO trouve dans sauvegarde contient un fichier plus récent celui à sauvegarder, c'est l'utilisateur qui doit décider quoi faire (cf. Fichiers antidatés ).

Des fichiers ont été sauvegardés alors que je suis sûr qu'ils n'ont pas changé.

Ceci peut se produire au passage à l'heure d'été lorsque l'unité de sauvegarde utilise un système de fichiers FAT32.

À quoi ressemblent mes données sauvegardées ?

Le dossier PUKABO d'une unité de sauvegarde contient l'arborescence des dossiers sauvegardés ; par exemple, Z:\PUKABO\D\Projets PellesC est la sauvegarde de D:\Projets PellesC.

Les données sauvegardées peuvent être utilisées sans outil particulier.

Qu'est-ce que le rapport détaillé ?

Le rapport détaillé est un fichier texte (pukabo.log) sauvegardé à la racine de l'unité de sauvegarde. Il contient, pour chaque dossier sauvegardé, la liste de toutes les opérations, réussies ou non. Il peut être examiné avec un éditeur de texte tel que NOTEPAD.

Il contient aussi l'historique des 10 sauvegardes précédentes limitées à 10000 lignes.

J'ai supprimé des fichiers de mon ordinateur, subsisteront-ils dans PUKABO\ après une sauvegarde ?

Les données qui n'existent plus dans votre ordinateur seront supprimées du dossier PUKABO\ de l'unité de sauvegarde. En fait, elles sont déplacées dans PUKAB_\. Ce dossier contient la version précédente des fichiers sauvegardés.

J'ai effacé un fichier par erreur ; puis-je le retrouver dans l'unité de sauvegarde ?

La première chose à faire est de d'examiner le contenu de la corbeille de Windows®.

Si vous n'aviez jamais fait de sauvegarde du fichier disparu, PUKABO ne peut pas vous aider.

Si vous en avez fait mais pas après la perte du fichier, vous avez de bonnes chances de le retrouver dans le dossier PUKABO\.

Si vous avez effectué des sauvegardes avant et après l'effacement, le fichier aura été enlevé de PUKABO\ ; vous devriez le trouver dans PUKABO_\ où ils restera jusqu'à ce qu'une nouvelle version de ce fichier soit créée et sauvegardée deux fois.

Le dossier PUKAB_\ semble grossir indéfiniment ; est-ce normal ?

Oui. Lors d'une sauvegarde, les fichiers obsolètes (mis à jour) et les fichiers supprimés (absent des répertoires à sauvegarder) ne sont supprimés ; ils sont déplacés dans PUKAB_\ où ne subsiste que la version précédente.

Ce répertoire ne devrait donc pas grossir trop rapidement. Il convient d'en faire une purge périodique avec l'explorateur de fichiers.

J'ai moins de données à sauvegarder, mais PUKABO\ est toujours aussi gros ; pourquoi ?

Les fichiers ou les répertoires de PUKABO\ ne sont effacés qu'à l'occasion d'une sauvegarde de leur contenu.

Un répertoire qui est retiré de la liste à sauvegardé restera présent indéfiniment dans PUKABO\.

Il convient de vérifier son contenu et de le purger de temps en temps, de même pour PUKAB_\ comme indiqué dans la question précédente.

J'utilise alternativement deux clés USB mais j'ai manqué un tour ; aurai-je des problèmes ?

Non, pas du tout. Si vous voulez savoir et avez assez de ports, insérez vos deux clés dans l'ordinateur ; PUKABO vous indiquera pour chacune d'elles ce qui a été sauvegardé et quand.

Comment désinstaller PUKABO ?

Pour désinstaller PUKABO, il suffit de supprimer son répertoire et les éventuels raccourcis.

PUKABO n'utilise pas le registre de Windows®. Les seuls paramètres de PUKABO concernent son aspect à l'écran (taille, position, couleurs). Ils sont mémorisés dans le fichier pukabo.ini à coté du programme.

Des erreurs se sont produites

Les causes possibles sont :

  • un fichier à copier ou supprimer est verrouillé, en cours d'utilisation ou a disparu ;
  • un nom de fichier comporte certains caractères diacritiques : vous devriez le renommer ;
  • opération sur un fichier en lecture seule : la première sauvegarde fonctionne normalement mais les suivantes généreront une erreur si le fichier a été modifié ;
  • l'unité de sauvegarde est pleine.

Qu'est-ce que la version PRO

La version PRO permet de définir un préfixe différent pour chaque ordinateur (la version standard utilise PUKABO). Le logiciel ne reconnaîtra alors que les éléments de sauvegarde de l'ordinateur où il est exécuté.

Ce réglage est effectué à l'installation du logiciel (le préfixe proposé par défaut utilise le nom de l'ordinateur).

Ces préfixes doivent être différents avant le dernier caractère (si vous utilisez PUK_PC1 and PUK_PC2, les données sauvegardées seront en sécurité dans PUK_PC1\ et PUK_PC2\, mais les versions précédentes seront mélangées dans PUK_PC_\).

Pour changer ultérieurement ce préfixe, il suffit de renommer le fichier PUKABO.exe avec le préfixe souhaité. Si des raccourcis sont utilisés, ils devront également être mis à jour.


Support multilingue

PUKABP peut s'adapter à différentes langues.

Si PUKABO trouve un fichier pukabo.msg file dans sons dossier, il l'utilise comme un dictionnaire de traductions. Ce fichier texte est facile à modifier :

  • Chaque ligne qui contient un signe égal définit une traduction : texte par défaut=traduction
  • Les autres lignes sont ignorées (peuvent être utilisées comme des commentaires).

Exemple pour le français (extrait) :

- - - Simple words

Yes=Oui

No=Non

STOP=STOP

Cancel=Annuler

Quit=Quitter

Help=Aide

- - - backup.c

START OF=DEBUT DE

END OF=FIN DE


Conditions d'utilisation

Ce logiciel est fourni tel quel, sans aucune garantie explicite ou implicite. En aucun cas, son auteur ne peut être tenu responsable de dommages ou de pertes résultant de l'utilisation du logiciel.

PUKABO est un logiciel gratuit. Cette licence vous autorise à utiliser ce logiciel gratuitement, aussi longtemps que vous le souhaitez, pour tout usage y compris pour des activités commerciales.

Vous pouvez modifier les fichiers de langue (*.msg) et la documentation.

Vous pouvez redistribuer gratuitement ce logiciel à condition de ne pas en déformer l'origine, de ne pas prétendre en être l'auteur.

Licence Creative Commons

Feddback

Il vous est suggéré de faire toute remarque à l'auteur : hserindat@gmail.com

Crédits

PUKABO a été développé avec PellesC ( http://www.smorgasbordet.com/pellesc/ ).